Safari ate my wiki! (updated)

unknown error en geen toegang tot proxy instellingenSafari Beta3 voor Windows is uit, dit kon U al uitgebreid lezen in de pers en natuurlijk ook in blogland. Als wannebe-mac-user met een boontje voor alles wat niet MSIE6 (yuck) is, ben ik verplicht Safari te downloaden, installeren en testen.

En ik zal maar direct met de deur in huis vallen: blijf er zo ver mogelijk van weg, Safari3 beta voor Windows is een slecht vermomde alpha release!

De “probleemkes” (waar we voor een beta nog mee zouden kunnen leven):

  • goh, die fonts zijn echt wel blurry (zelfs met ‘font smoothing’ op light)
  • keychain werkt niet: ik moet mijn proxy-wachtwoord elke keer opnieuw ingeven. ook al klik ik dat vinkje om username en pasword toe te voegen aan de keychain elke keer plichtsbewust aan.
  • sommige sites (die het perfect doen in FF en MSIE) laden amper of niet; de progress bar blijft op een gegeven moment gewoon hangen
  • ik krijg regelmatig de foutmelding “Safari can’t open the page” met detail “unknown error” ((null):10053)”. Als ik de pagina herlaad, krijg ik de pagina wel te zien.

De serieuze bugs (waar we al wat zenuwachtig van worden):

  • security researchers hebben enkele uren na release al beveiligingslekken gevonden (“designed to be secure form day one”?)
  • Safari is op mijn Windows XP toch alweer verschillende keren gecrashet
  • Ik kan niet aan de proxy-instellingen; die werden blijkbaar automatisch overgenomen van MSIE. De knop “Change Settings…” by Preferences/Advanced/ Proxies kan ik gewoon niet aanklikken. Ik kan Safari dus niet vertellen om, wanneer ik thuis ben, geen proxy te gebruiken. Geen Safari thuis dus.

Maar vooral … de absolute showstopper (eentje waar ik de stuipen van krijg): wanneer ik Safari gebruik om content toe te voegen op mijn wiki (Mediawiki 1.10.0, draait lokaal op mijn computer en werkt perfect) verdwijnt een deel van de tekst!!! WTF??? Scenario: open een wikipagina om te editeren, voeg ergens middenin een interne link toe (in wiki-markup iets als [[link]]) en submit. Ik weet niet wat dat bij u doet (comments zijn welkom), maar bij mij verdwijnt alles vanaf de nieuwe interne link! Ook getest op de Mediawiki sandbox en ook daar perfect reproduceerbaar. Omdat de wereld op meer draait dan wiki’s alleen heb ik ook een testje gedaan op andere sites en lap, ook daar verdwijnt content bij het submitten van een html-formulier met toegevoegde dubbele vierkante haakjes, accolades, backslashes, pipes, … Safari doet dus blijkbaar heel vervelende dingen met form-content die gepost wordt en is voor mij daarom in zijn huidige status eigenlijk totaal onbruikbaar als browser. En dat is volgens mij echt wel ongezien en onaanvaardbaar voor beta-software.

Ik ben ervan overtuigd dat Safari op Mac OS X een fantastische browser is. En ik twijfel er niet aan dat Safari op Windows uiteindelijk ook “best goed” zal zijn. Maar dit onding op de WWDC trots aankondigen als Beta van de snelste browser op Windows, seriously? Noem dit een alpha-release, Developer Preview of whatever, maar geen Beta. Want dat is, ondanks de eerste bewonderende kreetjes en jubelende blogposts, buitengewoon slechte marketing.

UPDATE: michel vuylsteke kan het dubbele-haakjes-probleem niet reproduceren. misschien zit één van de vele geheimzinnige company IT windows services hier voor iets tussen? Wie heeft de grote dubbele-haakjes-test al gedaan op zijn windows-safari? Iemand anders gelijkaardige problemen, of moet ik mijn XP-installatie hier inderdaad dringend wegvagen?

3 thoughts on “Safari ate my wiki! (updated)

  1. Pingback: Del.icio.us op 13 juni 2007 — Michel Vuijlsteke's Weblog

  2. Pingback: followup on safari3 in this newer post

  3. Pingback: futtta's blog

Leave a Reply

Your email address will not be published. Required fields are marked *